How to Fix IE Compatibility Issues in WordPress

wordpress กับ IE เพี้ยน

 

Some readers email me and ask me if there is way to fix IE compatibility issues in WordPress. IE has different versions, and if you site is not coded properly, your site might be appeared a lot different than you see on your IE. Especially IE10, your site might not ready for IE10, and visitors whom are using IE10 might not see the site as you could see it in IE9. Problems such layout messed up, font size differs and funny color are pretty common issues. However, there is way to solve this by using X-UA-Compatible Meta Tag.

To force your site to display the way how it should appear in IE9, all you can do is adding following code in your meta area, usually in header.

<meta http-equiv=”X-UA-Compatible” content=”IE=9″>

Of course, IE=9 can be change into different version as well. Following are the most common versions.

IE=6
IE=EmulateIE7
IE=7
IE=EmulateIE8
IE=8
IE=EmulateIE9
IE=9
IE=edge

Most of the above are pretty easy to understand; basically, it asks browser to render the website according to different version of browser. IE=edge, on the other hand, is asking browser to render the site to the latest browser possible.

Of course, keep in mind, you can only ask browser to render websites to older version of IE browsers, you can not ask it to render into newer version. For example, if you are using IE8 version, you can’t ask your browser to render the site using IE9.

 

Credit: Siteber.com

วิธีแก้ไขคือ
เปิด header.php ใน theme ที่ใช้งานอยู่ แล้วเพิ่ม บรรทัด

<meta http-equiv=”X-UA-Compatible” content=”IE=11″>

เข้าไปในส่วนของ header

<head>
<meta http-equiv=”X-UA-Compatible” content=”IE=11″>
</head>

 

image

Facebook Comments

Leave a Reply

Scroll to top